Kv6 coolant leak

Please post pictures, specifications and worklogs of your cars in here.

Moderators: guru, SJG

Post Reply
mrwilks01934
Regular Visitor
Posts: 89
Joined: Fri Sep 09, 2011 7:26 pm
Location: weston super mare
Contact:

Kv6 coolant leak

Post by mrwilks01934 » Mon May 16, 2016 9:43 am

Hi peeps my daily user ie a 1999 kv6 sterling auto fastback seems to have developed a coolant leak but I dont know where from ? as there is never a puddle of water on the ground I cant see any leaks anywhere only that a couple or so times a week I have to top up take this morning instead of the tank dropping from max to min it was empty so the leak must be getting worse I like to add there is no oil in the water and no water in the oil and she does not overheat so thats a good thing right?? I did hear about the three plastic coolant parts in the V of the engine that can let go with age could this be where the leak is coming from????? forgot to mention there is no internal leaks in to the cabin from the heater matrix or pipe work clips etc ie no wet carpets the dilema is I have never done any major strip downs on a kv6 engine all i have done on the honda 2.7 is a power steering pump and dizzy, any help pointers will be a blessing :( , the other problem I have been like it since the day I bought her I called her missy is she can missfire on tick over but as soon as you blip the throttle it clears can be like this for days or months then can be fine for days or months not sure what the problem is I changed the spark plugs recently but still does it i did hear about the coils being a weak point anybody got any ideas on that one ??? while Iam on a roll LOL missy is not very smooth changing into 2nd it can be abrupt snatchy where as first third and fourth are smooth Id like to point out it wasn't like this when i bought her I checked the gearbox oil recently still plenty doesn't smell burnt or look burnt either smells like new oil, I have to admit I had this problem on my very first 800 i ever owned a 1990 827si but was ten times worse 1st to 2nd was a nightmare car use to shake changing was like clonk bang, then I bought my second 800 a 1996 827 sterling in 2003 drove like a new car when bought then as time and mileage went by problems arose one of them is the 1st to 2nd gearbox problem not as bad as the si but a little worse than my kv6 I still own the 827 been off the road since 2012 but thats another post topic, I currently own six 800's soon to be seven its a 1998 kv6 sterling fastback in zircon silver same as missy so I will have twins one for me one for the missus I pick her up on the 28th of this month she looks in alot better condition than missy does not need the usual welding to the rear of the sills but and a big BUT she is stuck in limp home mode wont go above 30mph question is one what is causing this second have I bought a lemon and walk away or will it be an easy cheap fix answers on a post card please LOL the seller is an elderly gentleman seems very nice he even sent me a message the other day saying he has cleaned the car inside and out thats a first for me as normaly my past purchases are like mobile skips never vacuumed etc, like I have said I would be enternaly grateful if anybody can help verbably or pysically would be a bonus now Iam being cheeky LOL reason mentioned I have recently in the last couple of months being diagnosed with mild rheumatoid arthritis in both my hands and wrists so its going to get worse and I have lost some of my strength in my hands already even undoing the coolant cap causes pain on a bad day even my missus has said I think your days are number working on cars as it gets worse you will not be able to do any maintenance and Iam only 51 but hey hoe lifes a bitch but I love my 800's 99% of cars I have owned have been rover austin mg Ive had austin 1300's mg maestros austin allegro's even had a rare allegro equipe which somebody after me fully restored it.

Regards Tony Wilkins
Hi iam Tony, I currently have seven 800's a 1996 827 sterling, a 1996 820 vitesse turbo, a 1989 827 vitesse manual which needs a part/full resto, 1999 KV6 sterling,1998 KV6 sterling, 1998 vitesse turbo,1991 H Reg 827 vitesse Auto all fastbacks.

mrwilks01934
Regular Visitor
Posts: 89
Joined: Fri Sep 09, 2011 7:26 pm
Location: weston super mare
Contact:

Re: Kv6 coolant leak

Post by mrwilks01934 » Mon May 16, 2016 9:19 pm

Hi peeps 17 views no replies.

Bump

Regards Tony wilkins
Hi iam Tony, I currently have seven 800's a 1996 827 sterling, a 1996 820 vitesse turbo, a 1989 827 vitesse manual which needs a part/full resto, 1999 KV6 sterling,1998 KV6 sterling, 1998 vitesse turbo,1991 H Reg 827 vitesse Auto all fastbacks.

User avatar
BlueRover
Rover Guru
Posts: 1835
Joined: Mon Sep 01, 2008 7:39 pm
Location: Bolton, Lancashire
Contact:

Re: Kv6 coolant leak

Post by BlueRover » Mon May 16, 2016 10:45 pm

Hi Tony. 18 views and just my reply. It's always difficult with coolant leaks so perhaps no-one has a definitive answer.

My Mk1 820 lost a major amount of coolant one day. The engine got very hot. I refilled with water and apart from a very slight drop in level, hasn't done it since. I'm still at a loss as to where it went. I did run the engine the engine the other day and noticed a small droplet of coolant on the block. It seems to be coming from a silicone hose on the thermostat housing to top coolant rail. I'll be taking it off at the weekend and refitting it just to make sure it will seal properly. If you can, just go round the engine and make sure all the hoses are tight. A water leak may only show itself when the system gets up to operating temps and the pressure increases. Also, make sure the cap on the expansion tank is tight and seals well. Apart from that, I can't suggest anythng else.
Gordon:-
Only two 800's now,white 1991 820i with TWR and full special order leather (been stood for 15 years) and now a Nightfire red Tickford with 135k on the clock
Image

User avatar
BlueRover
Rover Guru
Posts: 1835
Joined: Mon Sep 01, 2008 7:39 pm
Location: Bolton, Lancashire
Contact:

Re: Kv6 coolant leak

Post by BlueRover » Mon May 16, 2016 10:52 pm

PS. I started life with a Hunter 1725DL and onto a GLs with the Holbay engine.
Then 2 Itals (1 saloon and one estate), 2 Montegos (both 1.6L) and then onto 800s. The first one I still have (a 1991 820i Special Edition with manual mirrors, sunroof and rear windows albeit with the ruched leather,TWR kit and 16" Speedline Sterling alloys), then a 1988 820SE fastback, a 1992 Si, a 1996 i (with 303,000 miles eventually) and currently driving the red 820 turbo in my sig.
Gordon:-
Only two 800's now,white 1991 820i with TWR and full special order leather (been stood for 15 years) and now a Nightfire red Tickford with 135k on the clock
Image

mrwilks01934
Regular Visitor
Posts: 89
Joined: Fri Sep 09, 2011 7:26 pm
Location: weston super mare
Contact:

Re: Kv6 coolant leak

Post by mrwilks01934 » Mon May 16, 2016 11:15 pm

hi gordon thanks for the reply, love your Mk1 820 turbo nice colour too.

Regards Tony
Hi iam Tony, I currently have seven 800's a 1996 827 sterling, a 1996 820 vitesse turbo, a 1989 827 vitesse manual which needs a part/full resto, 1999 KV6 sterling,1998 KV6 sterling, 1998 vitesse turbo,1991 H Reg 827 vitesse Auto all fastbacks.

User avatar
scoobyh123
Rover Guru
Posts: 10236
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: Kv6 coolant leak

Post by scoobyh123 » Mon May 16, 2016 11:26 pm

Only just spotted your thread Tony, there's a metal pipe that runs from one side to the other at the front of the car, just below the radiator. This can corrode and leak quite badly so could be the cause of your coolant disappearing.
More worrying though is the misfire - factor in the coolant loss and it suggests the head gasket is beginning to fail between a waterway and the combustion chamber. However it could equally be a pin-hole in a coolant hose spraying a jet of coolant onto a plug or coil pack or maybe even just a duff coil pack. You need to have the fault present and track it down to whichever cylinder is missing and go from there really.
Like Gordon says, coolant loss could be any number of things so maybe everyone else has looked, shaken their head and thought "head gasket again" and haven't wanted to say anything in case. It could also be the expansion tank or the cap on it. If the cap pressure spring has gone weak, the system won't pressurise correctly allowing coolant to boil off through the cap. This could also make a bit of moisture and possibly cause the misfire so worth renewing the cap, it will eliminate it as a possible cause if nothing else.

As for the silver ebay one stuck in limp mode, i saw it on ebay and thought it was a nice looking car. Not sure it has a limp mode on the KV6 but i could be wrong. Might be worth resetting the ECU to see if that sorts the problem.

Sounds like you'll be investing in some new toys to aid your tinkering, i've had to do similar for similar reasons. Still get days when even with the toys i can't do anything but they help a lot.
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

User avatar
traineefarmer
Rover Guru
Posts: 1276
Joined: Wed Dec 18, 2013 9:31 pm
Location: The executive parking bay.

Re: Kv6 coolant leak

Post by traineefarmer » Tue May 17, 2016 7:28 am

Leaking expansion tank cap is a good idea as these fail often and are cheap, but you would likely see tell tale water and scale marks around the top of the tank.

The KV6 on MEMS wouldn't a a limp mode like a modern car, but when a sensor or component fails it uses preset values to keep the car running, but the drop in performance is often barely noticable. Not being able to get above 30mph would point to multiple failures or some serious oily-but issues.

Might be worth finding someone with a Rover diagnostics set-up to see what's what.
Tom.

'97 Vitesse Coupe
'03 XC90 D5

mrwilks01934
Regular Visitor
Posts: 89
Joined: Fri Sep 09, 2011 7:26 pm
Location: weston super mare
Contact:

Re: Kv6 coolant leak

Post by mrwilks01934 » Tue May 17, 2016 12:28 pm

Hi Tom thanks for the tip I will keep an eye out for any leaks around the cap I never thought of that if it turns out thats the problem say its a cheap fix great, but why do we always think its the otherside of the coin oh no its going to cost hundreds and hundreds of pounds to fix that how I have been thinking all day, as with the one on ebay that I pick up on the 28th/29th of this month its not going to be the engine is it???, Iam thinking as I write this, maybe the gearbox is U/S or if what I heard years ago the kv6 has an ECU for the gearbox if true maybe thats faulty if not someone suggested reset the ECU under the bonnet, I don't know anyone on here or in the area I live privately or trade who would trust me to borrow the test equipment!!!!!, maybe someone on here might read this topic and offer to lend it to me ?? Iam committed to buying this car off ebay if as advertised is accurate I can walk away if falsely advertised, it will be cash on collection I have 100% feedback on ebay I always collect any cars I win, Iam really hoping its a cheap fix or just resetting the ecu will sort it.

Regards Tony
Hi iam Tony, I currently have seven 800's a 1996 827 sterling, a 1996 820 vitesse turbo, a 1989 827 vitesse manual which needs a part/full resto, 1999 KV6 sterling,1998 KV6 sterling, 1998 vitesse turbo,1991 H Reg 827 vitesse Auto all fastbacks.

User avatar
traineefarmer
Rover Guru
Posts: 1276
Joined: Wed Dec 18, 2013 9:31 pm
Location: The executive parking bay.

Re: Kv6 coolant leak

Post by traineefarmer » Tue May 17, 2016 8:35 pm

I don't think anyone on here has the equipment to test a late model 800. I only know of a handful of garages who still operate the rover diagnostics equipment.

And bear in mind that I saw one (a T4 unit) sell on ebay for around £4000, being trusted to borrow one is probably unlikely. Also being fairly old electronics, I'm told they weren't particularly user friendly and specific training was essential to get to the bottom of tricky Rover problems.

We're into the realms of things I know nothing about now and I am only repeating anecdotes I have been told by others. There are former Rover technicians and factory men on here who can probably go into more detail.

I'm sure someone posted a link on here once to a thread on the 75 forum where someone had compiled a list of garages with Rover Diagnostic capabilities.
Tom.

'97 Vitesse Coupe
'03 XC90 D5

User avatar
scoobyh123
Rover Guru
Posts: 10236
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: Kv6 coolant leak

Post by scoobyh123 » Tue May 17, 2016 9:32 pm

I'm fairly sure the Freelander somehow had the 2.5 KV6 shoehorned into it so maybe a Land Rover specialist would be able to help diagnose the problems if they aren't down to lack of use and/or "enthusiastic" use or if a reset on the ECUs doesn't cure the new one.
I think the 2.5 KV6 also found its way into the Kia Sedona but what management system it used i haven't the foggiest.
I think Best of British Rover has the diagnostic kit as well but not sure whether it covers all models.
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

stanker
Regular Visitor
Posts: 440
Joined: Mon Dec 08, 2008 2:17 pm
Location: Pembrokeshire

Re: Kv6 coolant leak

Post by stanker » Wed May 18, 2016 8:56 am

Hi Tony.

I had similar problems with the gear change on my 1998 KV6, after swapping the Jatco box, that sits under the front passenger side seat, the problem was solved.

Rheumatoid arthritis is an allergy to wheat and dairy, after giving up wheat and dairy, my arthritis has gone.

Regards

Ian

mrwilks01934
Regular Visitor
Posts: 89
Joined: Fri Sep 09, 2011 7:26 pm
Location: weston super mare
Contact:

Re: Kv6 coolant leak

Post by mrwilks01934 » Wed May 18, 2016 10:01 pm

Hi Ian Iam going to try and source a jatco gearbox ecu if all else fails thanks for the tip,

I was tested for celiac disease which came back negative around two years ago, I still have alot of the symtons, Iam in the process of changing my doctors so Iam going to ask to be tested again I know you have to keep eating wheat/gluten food stuffs for the test to be positive or if you stop eating wheat etc the test will give a false reading.

Regards Tony
Hi iam Tony, I currently have seven 800's a 1996 827 sterling, a 1996 820 vitesse turbo, a 1989 827 vitesse manual which needs a part/full resto, 1999 KV6 sterling,1998 KV6 sterling, 1998 vitesse turbo,1991 H Reg 827 vitesse Auto all fastbacks.

User avatar
scoobyh123
Rover Guru
Posts: 10236
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: Kv6 coolant leak

Post by scoobyh123 » Wed May 18, 2016 10:45 pm

mrwilks01934 wrote:Hi Ian Iam going to try and source a jatco gearbox ecu .

Regards Tony
There's one under the passenger seat of the car with the misfire Tony! :wink: :D

It would prove the point if nothing else and maybe save you buying another if it wasn't that.
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

Post Reply

Who is online

Users browsing this forum: No registered users and 21 guests