Mercedade's '97 Vitesse Lux

Please post pictures, specifications and worklogs of your cars in here.

Moderators: guru, SJG

Post Reply
mercedade
Rover Guru
Posts: 1294
Joined: Mon Nov 17, 2008 2:06 pm
Location: Manchester, UK
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Mercedade's '97 Vitesse Lux

Post by mercedade » Sat Jul 18, 2020 2:47 pm

I seem to have a huge amount of play in my wiper linkage. My drivers wiper will manage to both go off the screen on its upswing, and bash into the passenger wiper arm at the bottom of the downswing.

Any common refurb tips?
Adrian
1998 Rover Mk2 820 Vitesse Hatchback (white gold)
Gone...1998 Rover Mk2 820 Vitesse Hatchback (green)
Gone...1992 Rover Mk1 827 SLi Manual (green)
Gone...1998 Rover Mk2 825 Diesel (green)

User avatar
scoobyh123
Rover Guru
Posts: 10879
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: Mercedade's '97 Vitesse Lux

Post by scoobyh123 » Sat Jul 18, 2020 4:59 pm

mercedade wrote:
Sat Jul 18, 2020 2:47 pm
I seem to have a huge amount of play in my wiper linkage. My drivers wiper will manage to both go off the screen on its upswing, and bash into the passenger wiper arm at the bottom of the downswing.

Any common refurb tips?
I've not known a Mk2 to need wiper linkage refurb Adrian, i know the Mk1s used to wear the ends of the link arms so the wiper would jump about like a frog on a hotplate so if it's overshooting i'd suggest something has gone awry on the end of the link arm.

Best thing is have the plenum cover/scuttle panel and plastic trim under it off and have a look. You may be able to feel some slop in the linkage if you try moving the wiper arm which might give you some clue (from any noise you might hear) as to where the exact problem lies.

I did have several wiper linkages in the shed but have a horrible feeling i binned them as nobody ever seemed to need them.

Thinking outside the box, if it is a bush that's collapsed, i believe they're originally nylon and now NLA like most of the "silly little parts" you only need once in a blue moon. If that is the case, perhaps think outside the box and look at the Polybush universal bushes, fit a top-hat type bush in the hole and then push the ball of the linkage through and lock washer of some description. Just something to conjure with there! :wink: :D
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

mercedade
Rover Guru
Posts: 1294
Joined: Mon Nov 17, 2008 2:06 pm
Location: Manchester, UK
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Mercedade's '97 Vitesse Lux

Post by mercedade » Sun Jul 19, 2020 9:19 pm

Thanks Dave - if I get good weather on a convenient day, i'll take a look
Adrian
1998 Rover Mk2 820 Vitesse Hatchback (white gold)
Gone...1998 Rover Mk2 820 Vitesse Hatchback (green)
Gone...1992 Rover Mk1 827 SLi Manual (green)
Gone...1998 Rover Mk2 825 Diesel (green)

User avatar
Fastback
Regular Visitor
Posts: 397
Joined: Sun Feb 22, 2009 10:30 pm
Location: Lancaster
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Mercedade's '97 Vitesse Lux

Post by Fastback » Mon Jul 20, 2020 4:05 pm

Funnily enough I have just refurbed/replaced both my mk2 wiper linkages as the Sterling was doing what you describe. The Sterling was bad; there was no grease left in the sockets and the bearings were pitted, so replacement was really the only way forward. All new linkages and the pivots were packed with grease (there is a circlip so can dismantle). If you do get new linkages (hard) then pay attention the left (UK passenger) one as it has a kink in it and if put back the wrong way will catch the bodywork.

The, older, Vitesse I did some preventative work on, ie re-greased etc and it was interesting to note that the aluminium pivots are actually starting to corrode slightly. So after re-greasing the mech I put a load of grease in the plastic cap hoping to prolong the part.
Mark
'96 820 Vitesse Lux Fastback, rolling resto
'99 825 Sterling Fastback, up and running :D
'96 825 SLi Fastback, just waiting. :|
Previous:- 'J' 820Si Fastback, part Tickford
MG Maestro 2.0i (I loved that car, I did)

User avatar
Manalishi
Rover Guru
Posts: 2159
Joined: Wed Jun 03, 2009 2:38 pm
Location: Stockholm/Sweden
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Mercedade's '97 Vitesse Lux

Post by Manalishi » Tue Jul 21, 2020 5:50 am

I have a small memory from very long ago that I changed a nylon bush in my coupes linkage as one of the arms were flapping around. Not sure really but if I did it’s probably 10years ago. In the end I changed everything as the motor itself was failing. The interval wiping stopped in the middle of the wind screen and Brad (LTB) told me it was because of the engine was shot. I got a new LHD motor from him (still in the wrapping from Rover) and no problem since. But the bush I believe was swapped prior to that...

Sorry a bit off topic there. If anyone see Brad, please send my best wishes to him.
Henrik
Rover 820 Vitesse Coupe 180bhp -93 (Italy)
Rover 827 Vitesse manual (non cat) -89 (Spain)
Lexus GS450h -13
Honda Accord 2.4 Executive -04
Austin Seven Special -36
Austin Seven Ruby -36
Gone:
Rover 820 ti -95
Rover 216 coupe -93
Rover 620 ti -98

mercedade
Rover Guru
Posts: 1294
Joined: Mon Nov 17, 2008 2:06 pm
Location: Manchester, UK
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Mercedade's '97 Vitesse Lux

Post by mercedade » Thu Sep 17, 2020 1:47 pm

I haven't done my wipers yet...

Anyway - just wanted to check. On a very long decent (no throttle for at least 30 seconds, about 65/70pmh), the Vitesse temp gauge dropped right down and only warm (not hot) air was available.. So it's overcooling.

Suspect knackered stat, right?
Adrian
1998 Rover Mk2 820 Vitesse Hatchback (white gold)
Gone...1998 Rover Mk2 820 Vitesse Hatchback (green)
Gone...1992 Rover Mk1 827 SLi Manual (green)
Gone...1998 Rover Mk2 825 Diesel (green)

User avatar
scoobyh123
Rover Guru
Posts: 10879
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: Mercedade's '97 Vitesse Lux

Post by scoobyh123 » Thu Sep 17, 2020 3:12 pm

mercedade wrote:
Thu Sep 17, 2020 1:47 pm
I haven't done my wipers yet...

Anyway - just wanted to check. On a very long decent (no throttle for at least 30 seconds, about 65/70pmh), the Vitesse temp gauge dropped right down and only warm (not hot) air was available.. So it's overcooling.

Suspect knackered stat, right?
Right - does it take a long time to warm up as well? As in more than about 5 minutes?
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

mercedade
Rover Guru
Posts: 1294
Joined: Mon Nov 17, 2008 2:06 pm
Location: Manchester, UK
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Mercedade's '97 Vitesse Lux

Post by mercedade » Thu Sep 17, 2020 3:35 pm

I did notice that about 3 months ago, it used to warm up really fast, and then all of a sudden it took longer.

Not a long time, just long....er
Adrian
1998 Rover Mk2 820 Vitesse Hatchback (white gold)
Gone...1998 Rover Mk2 820 Vitesse Hatchback (green)
Gone...1992 Rover Mk1 827 SLi Manual (green)
Gone...1998 Rover Mk2 825 Diesel (green)

mercedade
Rover Guru
Posts: 1294
Joined: Mon Nov 17, 2008 2:06 pm
Location: Manchester, UK
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Mercedade's '97 Vitesse Lux

Post by mercedade » Thu Sep 17, 2020 7:19 pm

Sometimes, I've just got to write stuff down to make sense. Of COURSE it needs a new 'stat, can't even think why I checked.

It was new when I put the replacement head on, but that seems par for the course these days.
Adrian
1998 Rover Mk2 820 Vitesse Hatchback (white gold)
Gone...1998 Rover Mk2 820 Vitesse Hatchback (green)
Gone...1992 Rover Mk1 827 SLi Manual (green)
Gone...1998 Rover Mk2 825 Diesel (green)

User avatar
scoobyh123
Rover Guru
Posts: 10879
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: Mercedade's '97 Vitesse Lux

Post by scoobyh123 » Thu Sep 17, 2020 7:40 pm

Sounds about right! :roll: Things just don't seem to last these days! :(
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Who is online

Users browsing this forum: No registered users and 8 guests