Vitesse just passed mot

Please post pictures, specifications and worklogs of your cars in here.

Moderators: guru, SJG

Post Reply [phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
Racerm5
Regular Visitor
Posts: 89
Joined: Thu Mar 26, 2015 8:24 pm
Location: Ipswich
Contact:

Vitesse just passed mot

Post by Racerm5 » Sat Mar 21, 2020 9:49 pm

Hi all my vitesse mk1 has had head gaskets done and just passed mot....few jobs and paintwork to do
Image

Image

User avatar
scoobyh123
Rover Guru
Posts: 10870
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: Vitesse just passed mot

Post by scoobyh123 » Sun Mar 22, 2020 9:37 pm

Congrats on the pass Rick! Nice looking wee beastie too! :wink: :D
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

Racerm5
Regular Visitor
Posts: 89
Joined: Thu Mar 26, 2015 8:24 pm
Location: Ipswich
Contact:

Re: Vitesse just passed mot

Post by Racerm5 » Wed Mar 25, 2020 9:26 pm

Anyone know where I can get a pair of front shocks

User avatar
scoobyh123
Rover Guru
Posts: 10870
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: Vitesse just passed mot

Post by scoobyh123 » Wed Mar 25, 2020 10:23 pm

Racerm5 wrote:
Wed Mar 25, 2020 9:26 pm
Anyone know where I can get a pair of front shocks
They're currently out of stock (have been for a few months now) but keep an eye on it and they may return soon :

https://www.autodoc.co.uk/ashika/11669035

Big question is, have you got the lowered Vitesse springs on it? If not you'll get away with those, if you do then you'll need the Vitesse spec shocks becuase of shorter travel, sharper damping.
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

Racerm5
Regular Visitor
Posts: 89
Joined: Thu Mar 26, 2015 8:24 pm
Location: Ipswich
Contact:

Re: Vitesse just passed mot

Post by Racerm5 » Thu Mar 26, 2020 5:49 am

I’m not sure if it’s lowered but it doesn’t look it

Be nice if it was lol

Fitting c.v joint today...gotta knock on n/s front think the shock seems soft...will know more today

Thanks again for the help

User avatar
scoobyh123
Rover Guru
Posts: 10870
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: Vitesse just passed mot

Post by scoobyh123 » Thu Mar 26, 2020 8:09 am

Easy way is to measure the trim height.

Image

Chances are the noise is the drop links, they make a hell of a row but are still capable of passing an MoT!

When exactly does the noise happen and why do you say the shock is soft?
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

Racerm5
Regular Visitor
Posts: 89
Joined: Thu Mar 26, 2015 8:24 pm
Location: Ipswich
Contact:

Re: Vitesse just passed mot

Post by Racerm5 » Sun Mar 29, 2020 10:05 am

Thanks Dave will check it when back at work

It’s a drop link type knock from near side but haven’t driven it since cv joint been changed

I’m starting the bodywork now

The lcd display doesn’t work must be common and revs are a bit high when cold if you e come across anything before

Thanks again rick

User avatar
scoobyh123
Rover Guru
Posts: 10870
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: Vitesse just passed mot

Post by scoobyh123 » Sun Mar 29, 2020 10:20 am

Racerm5 wrote:
Sun Mar 29, 2020 10:05 am


The lcd display doesn’t work must be common and revs are a bit high when cold if you e come across anything before

Thanks again rick
Which LCD and what do you call a bit high on the revs Rick?
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

Racerm5
Regular Visitor
Posts: 89
Joined: Thu Mar 26, 2015 8:24 pm
Location: Ipswich
Contact:

Re: Vitesse just passed mot

Post by Racerm5 » Sun Mar 29, 2020 8:37 pm

The one under the stereo

Revs from cold about 1500rpm but settles after it warms up

User avatar
scoobyh123
Rover Guru
Posts: 10870
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: Vitesse just passed mot

Post by scoobyh123 » Sun Mar 29, 2020 9:07 pm

Racerm5 wrote:
Sun Mar 29, 2020 8:37 pm
The one under the stereo

Revs from cold about 1500rpm but settles after it warms up
There isn't one unless you have the VCM and then there's a choice of two.

Has the battery been disconnected recently for anything?
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

Racerm5
Regular Visitor
Posts: 89
Joined: Thu Mar 26, 2015 8:24 pm
Location: Ipswich
Contact:

Re: Vitesse just passed mot

Post by Racerm5 » Tue Mar 31, 2020 8:26 pm

Not sure what a vcm is
Yes it’s had a new battery but seemed ok at first
Might have a look at it during the week....might be worth cleaning out throttle body
I’m not very sure on this injection system
Will have a look at it

User avatar
scoobyh123
Rover Guru
Posts: 10870
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: Vitesse just passed mot

Post by scoobyh123 » Wed Apr 01, 2020 8:19 am

Racerm5 wrote:
Tue Mar 31, 2020 8:26 pm
Not sure what a vcm is
Yes it’s had a new battery but seemed ok at first
Might have a look at it during the week....might be worth cleaning out throttle body
I’m not very sure on this injection system
Will have a look at it
Vehicle Condition Monitor - display showing various parameters and fuel computer.

If it's recently had a new battery, leave it alone. It will sort itself out. Assuming that is that the battery is ok.

Most new batteries are silver-calcium technology which means they have a silver-calcium coating on the plates. In turn, this usually means they ned an extra ~0.1V per cell (6 cells in the battery) to start charging so they don't start charging until the alternator voltage is 14.7V minimum. The alternator on the car won't do this but i have come up with a modification so it will.

That said, some calcium batteries will charge on 14.4V, obviously the ones without too much of a coating on the plates. The problem arises if the battery isn't getting enough voltage to start the charging and then they gradually run flat over a period of use. Eventually this kills the battery.

Meanwhile, don't touch the injection system!
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

Racerm5
Regular Visitor
Posts: 89
Joined: Thu Mar 26, 2015 8:24 pm
Location: Ipswich
Contact:

Re: Vitesse just passed mot

Post by Racerm5 » Wed Apr 01, 2020 6:55 pm

It has had a new battery so will have a look

Thanks again

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Who is online

Users browsing this forum: No registered users and 20 guests