New to the group, so some pictures

Please post pictures, specifications and worklogs of your cars in here.

Moderators: guru, SJG

michaeljohnz55
Newbie
Posts: 26
Joined: Sun Apr 29, 2018 10:16 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: New to the group, so some pictures

Post by michaeljohnz55 » Tue Sep 04, 2018 6:44 am

Hi Dave. I've only just seen this, so apologies for the delay. Essentially I'm in the hands of a good mechanic whose time is so burdened with customers that he can't dedicate himself to this car. He has the right test equipment etc. The last call to him told me he had pretty much replaced everything from the rotary coupler, impact sensors SRS ECU etc and still can't remove the fault code. Thing is I think he just doesn't have the time and now he's had it for 2 months. Last call to him was to 'pull the plug' be he asked me to not do that and to let him continue - think his issue could be reading the T4 diagnostic. So at the end of the day just how long do i leave it with him? Could find out in another 2 months that it's still collecting dust. I've sent him every link i could find and also gave him a contact of a Rover mechanic - who works for another company - and to my knowledge he's had no time to look at what I've sent..i'm talking trade manuals specifically for SRS problems etc. so do i leve it with him indefinitely? Jury's out on that one Regards

User avatar
scoobyh123
Rover Guru
Posts: 10922
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: New to the group, so some pictures

Post by scoobyh123 » Tue Sep 04, 2018 8:56 am

Have a look at this Michael :

https://drive.google.com/drive/folders/ ... 3doenZlbE0

If you click on SRS Reset Pics.pdf it gives a procedure for resetting the SRS module fairly simply. The "dummy connnector" it refers to is bottom right of the cabin fusebox.

There is also some other information in other areas of that which might be helpful.

Something else i found recently (but can't remember where! :roll: ) was a Rover Tech Bulletin that said on certain cars, the wiring could need a resistor fitted due to the internal resistance of the passenger airbog going lower than the system expects to see. I can't for the life of me find or remember where this was! As soon as i do, i'll add it on here! :wink: :D
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

michaeljohnz55
Newbie
Posts: 26
Joined: Sun Apr 29, 2018 10:16 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: New to the group, so some pictures

Post by michaeljohnz55 » Thu Sep 06, 2018 12:32 am

Hi Dave as ever thanks for your advice. I've already accessed the Google drive..I'm going to call the mechanic this week. I'm increasingly of the view he doen't have the time to dedicate himself to this as opposed not know what he's doing. I wanted to bring the car back however he asked if he could hang on to it as he was determined to fix. In all if this when I telephone, it's always answerphone and when I get through I hear an absolutely stressed gabble. poor guy. If I find there has been no progress I'm thinking of asking to borrow the diagnostic gear for a few days as I have another mechanic who used to work on Rovers (and is familiar with the 'paperclip' flashing menthod) so all he needs is the diagnostic gear. Just a thought: I've seen adapter plugs on eBay designed to fit mine (?) with 4 pins on one end and 16 on the other end i.e to fit the more recent OBII equipment. does anyone have knowledge of this adapters? Here's an example: https://www.ebay.co.uk/itm/Car-OBD-OBD2 ... Sw2N5bg1xi

michaeljohnz55
Newbie
Posts: 26
Joined: Sun Apr 29, 2018 10:16 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: New to the group, so some pictures

Post by michaeljohnz55 » Thu Sep 06, 2018 12:34 am

Could be 2 pins, not 4..need to check again

User avatar
scoobyh123
Rover Guru
Posts: 10922
Joined: Sat Jul 11, 2009 10:27 pm
Location: Next door to Top Gun, Suffolk
Contact:

Re: New to the group, so some pictures

Post by scoobyh123 » Thu Sep 06, 2018 7:32 am

The OBD adaptor you linked to is for VAG vehicles Michael so certainly wouldn't work with any Rover - the two small plugs would be wrong for a start. Also the 827 wasn't ever OBD compliant and doesn't have an OBD socket. The only 800s that did were the last models (98-99 i believe) and even then, they used some strange Rover protocol that can't always be read by generic OBD readers, even on later models such as 25, 45 and 75 and the early Mini models.

I have no idea what protocol the early Rover system used but i do know it's usually only readable with the Rover kit, kind of annoying really as it's a relatively simple system compared to something like the fuel injection system.

I think your best course of action is to borrow the kit from the mechanic, get the other one who has done the paperclip flashing on the dummy harness and keep your fingers crossed! Good luck with it, whichever way you do it! :wink: :D
Cheers,
Dave


'94 827 Sterling saloon
'88 Volvo 760 V6 Estate
All auto :D
Image
'95 827 Coupé LPG gone but not forgotten!

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Who is online

Users browsing this forum: No registered users and 25 guests